Deployment: Checkout not working

Postmortem

While working on mitigations for the existing deployment issues, we’ve introduced a regression which led to parallel instructions being executed during source code checkout. Unfortunately, this has not been covered well by the test suite. Due to the multithreaded and asynchronous architecture, it took a while to discover and debug the cause. After the issue has been identified, we quickly created a new release of the deployment server and added unit tests.

Posted Jul 01, 2025 - 12:59 CEST

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 10:55 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2025 - 10:00 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 01, 2025 - 09:56 CEST

Investigating

We are currently investigating this issue.
Posted Jul 01, 2025 - 09:07 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 01, 2025 - 09:01 CEST
This incident affected: Instance provisioning eu-central-1 (management node for trusty clients - tier S2, management node for bionic clients - tier S1, management node for bionic clients - tier S2, management node for focal clients - tier S1, management node for focal clients - tier S2, management node for jammy clients - tier S1, management node for jammy clients - tier S2), r3 suite, and Instance provisioning eu-west-1 (management node for bionic clients - tier S2, management node for focal clients - tier S2, management node for jammy clients - tier S2).