Scaling is currently not working for Ubuntu 22.04 Instances

Postmortem

A new minor version of our configuration management system has been released lately. As we extend the package with some more value-added abilities, we subscribe to such releases to automatically build and publish extra packages providing more functionality. However, the build pipeline has not been triggered correctly so the package was missing while the new minor release depending on it was in use already. This has been uncovered by our alarming stacks and the package has been added to resolve the issue. For future updates, we are working on a more resilient mechanism to cope with this kind of promotions.

Posted Mar 21, 2025 - 14:22 CET

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 10:53 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 10:27 CET

Identified

We have identified the problem and are implementing a solution.
Posted Mar 21, 2025 - 09:50 CET

Investigating

Due to a provisioning error, auto scaling of EC2 instances is currently not working for Ubuntu 22.04
Posted Mar 21, 2025 - 09:49 CET
This incident affected: Instance provisioning eu-west-1 (management node for jammy clients - tier S2), Instance provisioning us-west-2 (mangement node for jammy clients - tier S1, management node for jammy clients - tier S2), and Instance provisioning eu-central-1 (management node for jammy clients - tier S1, management node for jammy clients - tier S2).