SES currently experiencing elevated rate of email throttles to Deutsche Telekom email recipients for some customers
Resolved
Announcements from AWS [Nov. 3rd update]
"Between October 15 6:20 AM PDT and November 2 9:10 AM PDT, emails that were sent to @t-online.de addresses could have experienced throttling which delayed delivery or timeouts which resulted in emails being returned as bounces. Bounced emails during this period were not delivered and would need to be re-sent. The issue has been resolved and the service is operating normally."
Posted Nov 03, 2022 - 19:39 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 27, 2022 - 10:50 CEST
Investigating
Announcements from AWS [Oct. 26th update]
"We are currently experiencing elevated rate of email throttles to Deutsche Telekom email recipients. This is caused by a change in Deutsche Telekom email receiving behaviour. Some customers experiencing throttles may experience a bounced email after the email sending retry period expires. The throttles are impacting a subset of the SES shared and dedicated IP address space across all SES regions. We are actively engaged with Deutsche Telekom to seek resolution of the throttling behaviour. To help expedite this, our recommendation is for impacted senders to have their recipients contact Deutsche Telekom for resolution."

As there is no official communication yet, we will keep you updated here. You may personal follow some resources at AWS e.g. https://repost.aws/questions/QU9c7_o7PPRpSOoG3Q8dJVZg/emails-sent-by-ses-to-germanys-largest-isp-always-bounce
Posted Oct 27, 2022 - 10:49 CEST
This incident affected: AWS region eu-central-1 (GERMANY) (AWS ses-eu-central-1), AWS region us-west-2 (US) (AWS ses-us-west-2), and AWS region eu-west-1 (IRELAND) (AWS ses-eu-west-1).